Przejdź do głównej zawartości

Testy biznesowe


Każdy wykonany test można zapisać. Testy są zapisywane dla wybranego testowanego algorytmu. Możesz także stworzyć nowy test - patrz: Tworzenie testu biznesowego. Testy mogą być również kopiowane wraz z wersją – za pomocą eksportowania do pliku.

wskazówka

Dane testowe mogą też zostać zapamiętane w celu wykorzystania ich podczas kolejnego testowania - patrz:Zapamiętywanie danych testowych.

W trybie testowym użytkownik ma możliwość zapisania danych testowych. Test po zapisaniu dostępny jest w panelu Testy algorytmów. Możliwe jest ponowne przeprowadzenie zapisanego dla algorytmu testu. Opcja ta umożliwia powtarzanie testów lub przeprowadzenie tylko wybranych testów dla jednej z wersji algorytmu.

  1. Wybierz przycisk image z paska dolnego lub z menu Widok opcję Testy algorytmów.
  2. Zostanie wyświetlony panel Testy algorytmów, w którym zebrane są wszystkie testy.
  3. Dzięki przyciskom funkcyjnym umieszczonym w górnej części panelu możesz uruchomić wszystkie lub tylko wybrane testy, odświeżyć struktury danych wyświetlić tylko poprawne lub błędne testy, itp.

image

Tworzenie testu biznesowego​

  1. Po wykonaniu testu danego algorytmu wybierz opcję Zapisz jako test biznesowy.

image

  1. Jeżeli tworzysz nowy test w oknie głównym wybierz Nowy, lub Plik>Nowy lub ikonę Nowy element i w kolejnym oknie wybierz Test biznesowy.

image

image

  1. W wyświetlonym oknie Nowy/test biznesowy wybierz, gdzie chcesz zapisać nowy test, wprowadź nazwę i kliknij OK.
  2. Stworzony test musi mieć w polu Algorytm oznaczony algorytm, którego dotyczy.

image

  1. Na obszarze roboczym określ dane wejściowe i oczekiwany wynik.
  2. Wprowadź – opcjonalnie – opis, a następnie potwierdź za pomocą przycisku Zapisz. Testy są zapisywane dla wybranego testowanego algorytmu. Testy mogą być również kopiowane wraz z wersją – umożliwia to eksportowanie do pliku.
  3. Wybierz przycisk image aby przejść do modelu, którego test dotyczy.

image

Po zapisaniu test będzie dostępny z poziomu panelu Testy algorytmów oraz z menu Testy. Patrz: Testy biznesowe.

Zapamiętywanie danych testowych​

Dane testowe mogą zostać zapamiętane w celu wykorzystania ich podczas kolejnego testowania. Możliwość zapamiętywania danych wprowadzonych podczas testowania może zostać włączona lub wyłączona przy użyciu znacznika Zapamiętywanie danych testowych dostępnego z poziomu opcji Opcje.

Zapamiętywanie danych działa następująco:

  1. podczas testowania należy wprowadzić dane wejściowe,
  2. po przetestowaniu należy zakończyć tryb testowania,
  3. przy ponownym testowaniu algorytmu dane wejściowe zapamiętane z wcześniejszego testowania są już wprowadzone.

W celu zapamiętania danych biznesowych przez System:

  1. Z menu Narzędzia wybierz Opcje.
  2. W wyświetlonym oknie Opcje wybierz zakładkę Testy.
  3. Zaznacz pole wyboru Zapamiętywanie danych testowych.
  4. W polu Ilość zestawów wskaż ilość zestawów danych wejściowych dla różnych algorytmów.

image

  1. Dla każdego algorytmu zapamiętywany jest jeden zestaw danych wejściowych. Ilość zestawów definiowana w oknie Testy oznacza ilość zestawów dla różnych algorytmów, które mają zostać zapamiętane. Jeśli algorytmów jest więcej od zdefiniowanej ilości zestawów, to starsze pliki są kasowane.
  2. Dane testowe są zapamiętywane w razie zamknięcia i kolejnego uruchomienia trybu testowego. Po kolejnym uruchomieniu trybu testowego zapamiętane zostają ostanie dane wprowadzone dla algorytmów w trybie testowym.

Zobacz również​

Najczęściej popełnianie błędy

Algorytmy

Tabela