Przejdź do głównej zawartości

Panele


W menu Widok oraz na dolnym pasku dostępne są panele, które możesz włączyć i poprzez dostosowanie widoku umieścić w oknie aplikacji, w preferowanym miejscu. W zależności od tego, z jakim plikiem pracujesz będzie potrzebny dostęp do poszczególnych paneli. Przykładowo podczas pracy w z pakietami przetwarzania przydatne są panele: Testy pakietów przetwarzania czy Szukaj w pakietach przetwarzania.

Oprócz paneli, które dedykowane są do konkretnego komponentu, wyróżniamy także panele, które są niezbędne do pracy z każdym typem pliku jaki tworzymy. Zaliczyć do nich można panel: Serwer wersji, Właściwości, Przybornik oraz Lista błędów.

Włączanie paneli​

Jeżeli chcesz włączyć dany panel:

  1. wybierz z belki dolnej opcje wyświetlania zakładki Właściwości lub innej jaką chcesz włączyć.
  2. możesz także wybrać z menu Widok - opcję wyświetlenia danej zakładki,
  3. w przypadku panelu Właściwości możesz go także włączyć z poziomu edycji danego pliku w oknie roboczym. Kliknij prawym w dany element na designerze - przykładowo w dane pole na strukturze danych i wybierz opcję z menu kontekstowego.

image

Właściwości​

  Panel Właściwości

Dostęp do najważniejszych funkcjonalności i konfiguracji danego pliku dostępny jest z panelu Właściwości.

Bez względu na to, czy jest to formularz czy struktura danych, menu, lista, proces itp., panel Właściwości jest dostępny dla wszystkich elementów. Możesz tutaj skonfigurować najważniejsze właściwości, począwszy od nazwy po definiowanie akcji na formularzu, itp.

wskazówka

W zależności, w kontekście jakiego elementu jesteś, zakres danych jest różny, dostosowany do danego obiektu.

W panelu Właściwości mogą być wyświetlane właściwości całego pliku lub konkretnego obiektu. Przykładowo po utworzeniu formularza lub listy w panelu Właściwości znajdziesz ogólne cechy tych elementów, ale gdy zaznaczysz dany obiekt na formularzu typu pole lub akcję na liście, wówczas wyświetlane są parametry i właściwości zaznaczonego obiektu.

image

Przybornik​

  Panel Przybornik

Przybornik jest zbiorem poszczególnych bloczków systemowych, kontrolek, pól struktury danych formularza, które możesz za pomocą drag& drop przeciągać na obszar roboczy. Podobnie jak w przypadku panelu Właściwości, panel Przybornik także dostosowany jest do danego obiektu i będzie inny dla formularzy, list czy pakietów przetwarzania.- patrz film panel Przybornik.

image

Zobacz również​

Środowisko pracy

Panele

Funkcjonalności menu Narzędzia