Najlepsze praktyki
Kontekst
Jeśli w strukturze dokumentu przejdziesz do kontekstu konkretnego elementu, to po kliknięciu przycisku Sprawdź mogą i najprawdopodobniej wystąpią błędy o treści:
„Element danych ma zdefiniowaną ścieżkę poza aktualnym kontekstem struktury”

W powyższym przykładzie użytkownik znajduje się w kontekście Dane_wniosku.
Aby poprawnie przetestować cały dokument należy wyjść z kontekstu i testować na całej strukturze:

W powyższej strukturze użytkownik znajduje się w kontekście Cała struktura i opisywany błąd nie powinien wystąpić.
Używanie podszablonów
- Jeśli używasz znacznika podszablonu w celu wstawienia do innego dokumentu, pamiętaj aby dokument Word, który wykorzystujesz, miał tak samo zdefiniowane style jak w dokumencie głównym. W przeciwnym przypadku style użyte w podszablonie zostaną zamienione na style z dokumentu głównego, co może spowodować znaczące różnice w wyglądzie między dokumentem bazowym, a jego wersją użytą jako podszablon w dokumencie głównym.
- Jeżeli chcesz używać innych styli w podszablonie niż w dokumencie głównym – nazwij je inaczej niż style używane w dokumencie głównym i innych podszablonach. Style o nowych nazwach zostaną dodane do dokumentu głównego podczas operacji wstawiania podszablonu.

- Nie stosuj podszablonów w elementach dokumentu MS Word takich jak nagłówek i stopka. Przy próbie takiego wykorzystania znacznika, aplikacja zgłosi błąd i może nie wygenerować takiego dokumentu lub dokument zostanie wygenerowany z błędami.

- Podobnie jak z czcionkami także nagłówek i stopka jest dziedziczona z szablonu głównego.

Czcionki
- Jeżeli chcesz użyć dodatkowe czcionki w dokumencie, dodaj je do katalogu Windows na serwerze, na którym jest zainstalowana funkcjonalność Generowania dokumentów. (Najczęściej po ściągnięciu pliku z czcionką klikamy na niego prawym przyciskiem myszy i instalujemy czcionkę w systemie).
- Zwróć szczególną uwagę na opcję załączania czcionek do dokumentu MS Word.

- W przypadku osadzenia czcionek w dokumencie mogą się pojawić problemy wydajnościowe z racji dużego rozmiaru takiego dokumentu, dlatego też zaleca się aby czcionki nie były dołączane do dokumentu/szablonu (ustawienie jak na obrazku powyżej).
Problemy z uruchomieniem dodatku archITekt w MS Word
W przypadku wystąpienia problemów z uruchomieniem dodatku archITekt , na przykład g dy dodatek cyklicznie nie uruchamia się podczas włączania MS Word, nie pojawia się zakładka archITekt lub po manualnym włączeniu dodatku w opcjach, przy próbie edycji nie pojawia się zawartość w zakładce Atrybuty - naprawić niepoprawne działanie dodatku najłatwiej można w sposób odinstalowania i ponownego zainstalowania dodatku za pomocą instalatora. Istnieje również ręczny sposób naprawy takich problemów, nie wymagający pełnej reinstalacji dodatku:
- Włącz MS Word.
- Przejdź do Plik->Opcje->Dodatki, wyszukaj na liście VDS i zapamiętaj ścieżkę do folderu:

- Przejdź do Zarządzaj->Dodatki COM->Przejdź, w liście wybierz dodatek VDS i kliknij Usuń (czasami dla użycia tej opcji niezbędne jest uruchomienie MS Word w trybie administratora).

-
Otwórz w eksploratorze plików folder VDS (ścieżka z kroku 2). Uruchom plik VSoft.Document.Services.Addin.vsto. Domyślnie powinien posiadać poniższą ikonkę:
-
Po zakończeniu instalacji, włącz MS Word i sprawdź czy zakładka VDS pojawiła się po uruchomieniu.
-
W podobnych wypadkach warto sprawdzić klucz rejestru
HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\VSoft.Document.Services.AddinZnacznik LoadBehavior w prawidłowym wypadku powinien mieć wartość 3 (3 - automatyczne odpalenie. 0 – MS Word nie próbował załadować dodatku). -
Żeby wejść do edytora rejestru trzeba wcisnąć przycisk Windows + R, w okienku wpisać „regedit” i wcisnąć Enter.
Dodawanie obrazów do dokumentu
- Przy wstawianiu obrazów, zarówno do znaczników VDS jak i do zwykłej treści dokumentu, zalecane jest używanie opcji Kopiuj – Wklej.
- Wklejanie obrazów za pomocą opcji MS Word Wstawianie -> Obrazy może powodować zawieszenie programu MS Word przy otwarciu dokumentu na innym komputerze niż ten, na którym dokument został stworzony. Ten problem występuje, ponieważ przy użyciu opcji Wstawianie -> Obrazy do dokumentu jest wstawiany nie obraz, a odnośnik do pliku źródłowego na komputerze, i przy otwarciu dokumentu na innym komputerze odnośnik będzie prowadził do nieistniejącej lokalizacji. Natomiast, przy użyciu opcji kopiuj – wklej, obraz dodaje się jako integralna część dokumentu i jego źródło jest przechowywane w samym pliku docx.
Punktory
- Problem zawieszenia programu MS Word również występuje przy definiowaniu własnych punktorów, jeśli jako marker punktora zostanie wybrany obrazek (funkcja Punktory -> Zdefiniuj nowy punktor -> Obraz…). Ta funkcja zawsze powoduje wklejanie obrazka jako odnośnika do źródła zewnętrznego, co powoduje zawieszenie programu MS Word na niektórych komputerach. Zalecane jest używanie domyślnie dostępnych punktorów, dodawanie obrazków za pomocą opcji Wklej oraz, w miarę możliwości, ogólne unikanie korzystania z zaawansowanych funkcji programu MS Word.
Numerowanie i punktowanie elementów w znaczniku Iteracja
W przypadku, gdy chcemy zastosować numerację używając listy numerowanej z opcji dostępnych w programie MS WORD, i dodatkowo aby numeracja poszczególnych wyników rozpoczynała się zawsze od numeru 1 w obrębie danej grupy należy wykonać następujące kroki:
- Poziom 1 czyli główny (w rzeczywistości ma być on nienumerowany) - wstaw znacznik i ustaw kolor punktoru na biały.
- Poziom 2 czyli podlista do poziomu pierwszego - (w rzeczywistości ma być numerowany) - wstaw znaczniki i ustaw numerowanie w opcjach WORD.
- Poziom 3 czyli podlista do poziomu drugiego, wypunktowanie do listy numerowanej - wstaw znaczniki i ustaw wypunktowanie w opcjach WORD.

Przykład wygenerowanego dokumentu:

Używanie znaczników w nagłówku i stopce
Znacznik, który możesz używać w nagłówku i stopce to znacznik Wartość.
W przypadku użycia pozostałych znaczników w nagłówku lub stopce mogą pojawić się błędy walidacji lub błędy w wygenerowanym dokumencie. Przy próbie zapisania takiego dokumentu będą wyświetlane komunikaty i ostrzeżenia więc należy mieć to na uwadze i sprawdzić czy dane znaczniki generują się i czy dane wygenerowane przez znacznik prezentują się poprawnie. Taki dokument z błędami walidacji można zapisać
W poniższym przykładzie w nagłówku użyto znaczniki: Iteracja, Warunek, Obraz, Wartość, Kod oraz Podszablon. Zapisano dokument z błędami i ostrzeżeniami oraz testowo wygenerowano.
W tym przypadku dokument został wygenerowany poprawnie aczkolwiek podkreślamy, iż należy mieć na uwadze, że w innych przypadkach dokumenty mogą być wygenerowane błędnie lub w ogóle się nie wygenerować.
