Przejdź do głównej zawartości

Przebieg procesu


Możesz zweryfikować przebieg procesu.

  1. Zapisz proces.

  2. Uruchom proces na jeden z dwóch sposobów:

    • wybierz przycisk Uruchom proces na pasku narzędzi nad obszarem roboczym procesu,
    • w drzewie Serwera wersji kliknij prawym przyciskiem myszy na procesie i z menu kontekstowego wybierz Uruchom proces....

    Opcja dostępna jest dopiero po zapisaniu wersji procesu.

  3. Przebieg procesu możliwy jest do podglądu, jeżeli w procesie nie występują błędy walidacji i wersja jest poprawna.

Obraz 101

  1. Przebieg procesu wyświetlany jest na osobnej karcie, gdzie nie ma możliwości edycji elementów procesu.
  2. W trakcie przebiegu, kroki procesu, które nie zostały jeszcze wykonane są wyszarzone natomiast linia przebiegu procesu jest pogrubiona.
  3. Jeżeli w procesie została wykorzystana czynność, która wymaga wykonania akcji na formularzu, wówczas proces zostanie uśpiony do czasu, aż nie zostanie wykonana jedna z akcji. W takim przypadku możesz kliknąć na czynność i otworzyć w przeglądarce WWW formularz skojarzony z daną czynnością.

Obraz 102

  1. Po wykonaniu jednej z akcji na formularzu i powrotu do karty z przebiegiem procesu widać, iż proces będzie dalej kontynuowany.
  2. Jeżeli zamkniesz kartę z przebiegiem procesu, możesz do niej wrócić z poziomu menedżera procesów. Wybierz z menu Narzędzia opcję Menedżer procesów, odszukaj proces na liście, kliknij prawym przyciskiem myszy i wybierz z menu kontekstowego Śledź wykonanie.

Obraz 107

Szczegóły przebiegu procesu​

Na panelu Szczegóły przebiegu procesu prezentowane są poszczególne kroki, które proces wykonuje.

  1. Aby móc śledzić szczegółowe kroki procesu wybierz z menu głównego opcję wyświetlania karty z przebiegiem procesu. Wybierz z menu Widok opcję Szczegóły przebiegu procesu, lub kliknij w ikonę uaktywniającą kartę na pasku dolnym.

Obraz 7

  1. Możesz śledzić przebieg procesu na panelu, który jest aktualizowany wraz z kolejnymi krokami, przez które przechodzi proces.
  2. Ponadto po zaznaczeniu danej czynności na panelu Właściwości możesz podejrzeć konfigurację elementów procesu.

Obraz 127

Okno szczegółów czynności​

Obok elementów wyświetlane są informacje o wykonaniu procesu oraz ostrzeżenia.

  1. Kliknij w element aby przejść do szczegółów wykonania i treści wyjątku.

Obraz 103

Okno szczegółów czynności zawiera dane:

  1. Szczegóły – ogólne informacje podstawowe dot. wykonania czynności.
  2. Wyjątek – informacje jeśli w czynności wystąpił błąd.
  3. Dane wejściowe/wyjściowe – dane wejściowe wyjściowe przekazywane w czynnościach Algorytm, Tabela, Usługa sieciowa.
  4. Wersja modelu/tabeli z daty – informacje o wykorzystaniu modelu tabeli z konkretnej daty obowiązywania w czynnościach Algorytm, Tabela.

Obraz 9

Właściwości przebiegu procesu​

Panel Właściwości na karcie przebiegu procesu prezentuje szczegółowe informacje o procesie.

  1. Przejdź do karty z przebiegiem procesu.
  2. Kliknij gdziekolwiek na obszarze roboczym w puste miejsce i przejdź do panelu Właściwości. (Ważne aby żaden element nie był zaznaczony, gdyż wtedy na panelu Właściwości wyświetlane są szczegóły zaznaczonego elementu).

Obraz 10

Przebieg procesu z wykorzystaniem mechanizmu aktorów procesu​

Procesy wyposażone zostały w mechanizm aktorów procesu, który na czynności Stan, na panelu Właściwości umożliwia wskazanie wykonawcy procesu.

image

Wykonawca procesu może także zostać określony poprzez akcję na formularzu. Patrz: Mechanizm aktorów procesu.

W takim przypadku w podglądzie przebiegu procesu przy czynności Stan wyświetlana jest ikona wykonawcy. Aby sprawdzić, kto jest aktualnym wykonawcą procesu:

  1. Na karcie przebiegu procesu kliknij ikonę wykonawcy przy czynności Stan. Zostanie otwarte okno Szczegóły wykonania czynności.
  2. W sekcji Kolejne uruchomienia czynności wybierz uruchomienie, które chcesz sprawdzić.
  3. W sekcji Szczegóły zaznaczonego uruchomienia czynności przejdź na zakładkę Wykonawca. Wyświetlany jest tu identyfikator wykonawcy, który możesz skopiować przyciskiem Skopiuj do schowka.

Na poniższym przykładzie wykonawca czynności Stan jest wyznaczany formułą ID.BIEŻ.UŻYTK (widoczną na panelu Właściwości w polu Wykonawca), czyli jest nim bieżący użytkownik. Proces został uruchomiony przez zalogowanego użytkownika aplikacji, dlatego na zakładce Wykonawca widoczny jest jego identyfikator – w tym przypadku 1.

image

Eksport przebiegu procesu​

Z poziomu archITekt Studio można wyeksportować przebieg każdego procesu, który został uruchomiony.

wskazówka

Jeśli eksportujesz przebieg niezakończonego procesu jego dane mogą być niekompletne.

  1. Na karcie przebiegu procesu wybierz przycisk Eksportuj na pasku narzędzi w prawym górnym rogu (obok listy uruchomień procesu). Zostanie otwarte okno Eksportuj.
  2. W sekcji Ogranicz pobieranie procesów powiązanych określ, czy i do którego poziomu mają zostać wyeksportowane przebiegi procesów powiązanych:
    • Ogranicz pobieranie powiązanych procesów nadrzędnych do poziomu – liczba poziomów procesów nadrzędnych (wywołujących dany proces),
    • Ogranicz pobieranie powiązanych procesów podrzędnych do poziomu – liczba poziomów podprocesów wywoływanych przez dany proces.
  3. Opcjonalnie w sekcji Ogranicz pobieranie przebiegu do przedziału czasu zaznacz pola od i do i wskaż przedział czasu, z którego ma zostać wyeksportowany przebieg.
  4. Wybierz przycisk Eksportuj.

Obraz 2

  1. Eksport procesu lub kilku procesów możesz także wykonać z poziomu menedżera procesów.
  2. Przejdź do menedżera procesów (menu Narzędzia > Menedżer procesów).
  3. Zaznacz proces, kliknij prawym klawiszem i z menu kontekstowego wybierz Eksportuj przebiegi.
  4. Zaznacz kilka procesów z wciśniętym klawiszem Ctrl i wybierz akcję z paska dolnego.

Obraz 114

Wczytywanie przebiegu procesu​

Jeżeli wyeksportowałeś przebieg procesu, w każdej chwili możesz go wczytać do archITekt Studio.

  1. Przejdź do Menedżera procesów i wybierz przycisk umożliwiający wczytanie pliku z zapisem przebiegu procesu.

Obraz 13

  1. Możesz także wybrać opcję bezpośrednio z menu Narzędzia>Podgląd wyeksportowanego przebiegu procesu.

Obraz 14

Eksportowanie przebiegu procesu oraz wczytywanie jest funkcjonalne podczas pracy na różnych środowiskach w celach diagnostycznych. Możesz wyeksportować przebieg procesu z jednego środowiska (np. produkcyjnego), a następnie zaimportować na drugie (np. do siebie, na środowisko testowe itp.). Dzięki temu możesz prześledzić jak działa proces na innym środowisku bez dostępu do tego środowiska.

Eksport przebiegu procesu z poziomu WWW​

Wyeksportować proces możesz także z poziomu strony WWW.

  1. Przejdź do formularza, który korzysta z procesu i wybierz zakładkę Akcje.
  2. Uaktywnij Przybornik i w sekcji Procesy dostępne są akcje, które związane są z procesem i możesz je wykorzystać na formularzu.
  3. Przeciągnij akcję na okno designera. Akcje możesz dodać w wielu miejscach, w zależności od tego jak chcesz aby skonfigurowany był formularz.
  4. Jeśli dodasz akcję w sekcji Przyciski i akcje, wówczas akcja będzie przyciskiem, który możesz kliknąć na formularzu.
  5. Jeżeli dodasz akcję jako część składową akcji złożonej, wówczas akcja eksportu zostanie wykonana po naciśnięciu przycisku akcji złożonej W tym wypadku akcja złożona Zapisz i Eksportuj przebieg procesu, czyli po wybraniu akcji Zapisz na formularzu dane zostaną zapisane i pobrany eksport procesu.
  6. Na panelu Właściwości wskaż proces, którego przebieg ma zostać wyeksportowany.

Poniżej różne możliwości wykorzystania akcji Eksportuj przebieg procesu.

Obraz 20

Wygląd formularza według zdefiniowanych akcji i zdarzeń z użyciem akcji Eksportuj przebieg procesu.

Obraz 22

Zobacz również​

Formularz podglądu

Menedżer procesów

Testowanie procesu